Kicad

De Centre de Ressources Numériques - Labomedia
Aller à : navigation, rechercher

Créer un pcb simple face avec Kicad


Ceci n'est pas un vrai tutoriel, plutôt quelques trucs pour ne pas devenir fou devant cette suite de logiciels...Il s'agit donc de solutions plus ou moins barbares face à quelques problèmes rencontrés.
Ici de la documentation pour bien commencer : http://kicad-pcb.org/help/documentation/

Présentation

Kicad est une suite de logiciel permettant de créer des schémas électroniques puis d'en faire des pcb.
http://www.kicad-pcb.org

Création du schéma avec Eeschema

Lorsque que l'on à placé et relié nos composants il est important de rechercher les erreurs que nous avons faites en cliquant sur la petite coccinelle. Celle-ci nous indique où il y à problèmes...

Power flag

Pour valider notre schéma il faut placer sur les partie d'alimentation un symbole PowerFlag sur chaque ligne la constituant (en plus des habituelles +12v et GND par exemple).

Kicad-PowerFlag.png

Labels globaux

Si notre schéma est difficile à lire il est possible de placer des labels globaux pour à léger le nombre de connexions. Dans la colonne de droite de l'interface sélectionner : Label-global.png
Il faut donner exactement le même nom à chaque label pour créer une connexion.

Kicad-GlobalLabel.png

NoConnect

Lorsqu'un composant à des connections vide il faut lui ajouter des petites croix...

Kicad-noConnect.png

Association des composants avec CvPcb

Il y à parfois des composants qui ne s'associent pas correctement avec notre schéma, il manque donc des liaisons sur notre chevelu lorsqu'on l'importe dans pcbNew.

Kicad-chevelukipu.png

Pour remédier à cela il faut trouver une empreinte similaire même si le composant n'est pas le bon...
Par exemple dans ce schéma je dois utiliser un régulateur de tension 5V (L7805) mais il n'affiche pas de connexion dans PcbNew je l'ai donc remplacer par un LM7806ACT... et là tout va mieux...c'est un peu barbare mais efficace.
Il faut tout de même faire attention à la numérotation du brochage des composants (1 2 3 et pas 1 3 2 par exemple)

  • Trouver des nouvelles empruntes de potentiomètres Alpha 09

https://github.com/nutbolt/Potentiometers.pretty

Création du pcb avec PcbNew

Pour faire un pcb simple face il y à quelques règles de conceptions à modifier dans Règles de conceptions -> Options Couches

  • 2 couches, composants sur le dessus uniquement
  • sélectionner jumper pour la face du dessus

Kicad-OptionCouche.png

Règles de conceptions

Afin de régler l'épaisseur des pistes et l'isolation entre celle-ci il faut modifier les règles de conceptions.
Kicad-regleConception.png


Kicad-reglesGeneral.png

Forme de découpe (edge cut) avec inkscape

Pour créer des formes arrondies, triangulaires ou n'importe quoi on peu créer un fichier dxf avec inkscape et l'importer dans kicad.

Créer une forme

Kicad-cut-inkscape1.png

Objet en chemin

Une fois la forme créer, sélectionner la puis transformer la en chemin

menu Chemin > Objet en chemin

Ajout de nouveaux noeuds dans les courbes

  • Sélectionner les points qui forment la courbe

Kicad-inkscape-cut-2.png

  • Ajouter quelques noeuds au milieu du segment sélectionné, en cliquant là : Kicad-inkscape-cut7.png

Rendre rectiligne les segments sélectionnés

en cliquant ici :Kicad-inkscape-cut-4.png
Voilà ce que ça donne :
Kicad-inkscape-cut-5.png


Enregistrement du fichier dxf

menu Fichier > Enregistrer sous > DXF R14

Importer la forme dans kicad

Fichier > Importer > DXF 

Ne pas oublier de sélectionner la couche dans laquelle on veux notre forme
Kicad-inkscape-cut-6.png

Auto routage

Depuis quelque temps l'option freeroute à disparu mais il est toujours possible de l'utiliser, voici la marche à suivre :

Installer Netbeans (un IDE java)

sudo apt-get install netbeans

ou télécharger la version java SE ici

  • Installer au besoin jh.jar et netx.jar(des fichiers d'aide) :
sudo apt-get install javahelp2 icedtea-netx-common

Copier les sources de FreeRouting

dans le dossier de votre choix

git clone https://github.com/nikropht/FreeRouting.git

Lancer et configurer NetBeans

Créer un nouveau projet

  1. File>New Project
  2. Java > Java Project with Existing Sources
  3. Name and Location : FreeRoute (par exemple)
  4. Existing sources : Source Package Folders > Add Folder... (Ajouter le dossier précédemment téléchargé : .../FreeRouting)
  5. Cliquer sur Finish pour construire le projet

Configurer NetBeans

Une fois le projet lancer Faire un clic droit sur Freeroute dans l'onglet Projet et cliquer sur Properties

  • dans la catégorie Librairies > Add JAR/Folder et indiquer le chemin suivant :
/usr/share/java/jh.jar

puis recommencer avec

/usr/share/icedtea-web/netx.jar

puis cliquer sur OK

  • dans la catégorie Application > Web Start cliquer sur Enable Web Start puis cliquer sur OK

FreeRoute

  • Construire ou compiler le projet

cliquer sur le petit marteau

  • Lancer FreeRoute

dans un terminal

java -jar "/home/là où se trouve votre projet/NetBeansProjects/FreeRoute/dist/FreeRoute.jar"
  • Pour l'utilisation se référer à ce site

http://www.wayneandlayne.com/blog/2013/02/27/kicad-tutorial-using-the-autorouter/

SourceS

http://www.muonhunter.com/blog/installing-freerouting-on-kicad
https://en.wikibooks.org/wiki/Kicad/Autorouter

Création de fichiers gerber

Le format Gerber permet d'avoir toutes les couches de notre pcb dans des fichiers séparés : gravure des piste(.gbl), perçage des trous(.drl) et découpe du circuit(.gbr).

Définition de l'origine

Dans PcbNew il est important de placer l'origine des coordonnées de perçage et de la grille pour avoir un point d'origine correct dans le gcode qui en découlera.

Kicad-origine.png

Création des fichiers Gerber

  • Pour créer nos différents fichiers il faut cliquer sur Tracer dans le menu Fichiers ou directement sur l'icône avec une imprimante et un P.
  • Ensuite il faut sélectionner Utiliser un axe auxiliaire comme origine.
  • Et cliquer sur tracer pour créer les fichier de gravure et de coupe

Kicad-gerberTracer.png

  • Faire de même pour le fichier de perçage

Kikad-percage.png

  • Pour visualiser le résultat il est possible d'utiliser GerbView ou gerbv

Aller dans l'onglet File -> Import Layer(s)
et séléctionner les fichiers .drl .gbr .gbl
Kicad-gerbv.png

Test des fichiers

Un visualiseur en ligne : http://www.gerber-viewer.com/
Kicad-gerber-viewer.png

Création du gcode avec pcb2gcode

voir ici Pcb2gcode

Exporter la liste des composants (BOM)

Exporter un fichier .csv depuis Pcbnew : > Fichier > Fabrication Outputs > BOM