GrandMA2

De Centre de Ressources Numériques - Labomedia
Révision de 14 janvier 2017 à 17:14 par Mushussu (discussion | contributions) (Déclenchement à l'intérieur d'une boucle)

(diff) ← Version précédente | Voir la version actuelle (diff) | Version suivante → (diff)
Aller à : navigation, rechercher

Configuration réseau

Relier deux entités

Par exemple, relier une GrandMA2 avec un ordinateur avec GrandMA OnPC dessus ou GrandMA 3D Utiliser un câble ethernet de catégorie 5e avec comme norme de blindage UTPn c'est-à-dire sans blindage d'une longueur < 70m en le branchant entre les deux entités. Pour que le dialogue puisse s'établir, il faut que les versions des différents logiciels soient compatibles. Il faut que les trois premiers nombres soient égaux. (Par ex. Une GrandMA2 avec un firmware 3.2.2.13 pourra dialoguer avec un MA 3D version 3.2.2.3, mais pas avec un un version 3.1.2.5).

Echange de données avec plus de deux entités

Pour cela, il est préférable d'utiliser un ou des switchs non-paramétrables avec une vitesse de 1GB/S

Paramétrer les cartes réseaux

Sur la console GrandMA 2

Setup / MA Network Control / Station IP

Entrer une adresse IP par exemple

192.168.1.1

Sur un micro-ordinateur

Windows > Paramètres > Réseau et Internet > Ethernet > Centre réseau et Partage Cliquer sur la carte réseau idoine Propriétés > Protocole Internet version 4 Cocher le bouton

Utiliser l'adresse IP suivante

Entrer une adresse IP par exemple :

192.168.1.101

Puis cliquer sur le champ masque de réseau qui se remplie automatiquement et sera de la forme

255.255.255.0

Valider les différentes fenêtres

Vérifier la configuration

Windows > Système Windows > Invite de commandes Dans la fenêtre qui s'ouvre, vous pouvez taper :

ipconfig

Les différentes cartes réseau vont s'afficher, vérifier que l'adresse de celle utilisée corresponde aux valeurs entrées précédemment.

192.168.1.101

Dans ce cas, vérifier la communication avec la GrandMA2. Taper ping puis l'adresse IP de la GrandMA2 par exemple :

ping 192.168.1.1

Normalement, des lignes devraient apparaître :

Réponse de 192.168.1.1 : octets=32 temps<1ms TTL=128

Création d'un nouveau spectacle

Bien organiser la console

[Backup] > [New Show] Pour sélectionner tous les éléments à effacer cliquer sur

[Check All] 

Changer le nom du spectacle Pour créer une nouvelle conduite valider avec

[Please] 

Valider les fenêtres suivantes Puis fermer la fenêtre popup

Si vous voulez sauvegarder sur une clef USB, il faut qu'une clef soit insérer dans un des ports USB.

Création d'un utilisateur

Création d'un profil utilisateur

[Setup] > [User & Profiles Setup]

Puis cliquer sur new avec un clic droit ou la roue N°5 dans la table Showing 'UserProfiles'

[New]

Pour changer le nom du profil utilisateur clic-droit sur le nom taper le nom par exemple :

Laurent-profil

Attention éviter les espaces car les noms de fichier n'accepte pas les espaces ni les caractères accentués

Création d'un utilisateur

Cliquer avec un clic droit ou la roue N°5 sur New dans la table Showing 'Users' sur

[New]

Clic-droit sur le nom du nouvel utilisateur pour changer le nom. Puis clic-droit sur la ligne nouvellement créée dans la colonne UserProfile SI vous voulez choisir un mot de passe clic-droit dans la colonne Password Choisir dans le menu déroulant le profil créé. Fermer les fenêtres popup.

Se logger comme utilisateur

Tools > Login >

ou dans l'invite de commande

login Laurent motDePasse

Création d'une session

[Setup] > [MA Network Control]

Vous pouvez le nom de session en cliquant dessus ainsi que choisir un mot de passe Ensuite cliquer sur

[Create Session]

Utilisation des effets

Démarrer un nouveau spectacle pour l'exercice. Créer 12 Mac Aura

[Setup] > [Patch & Fixture Schedule]

Remplir le champ Layer avec Automatique. Choisissez votre projecteur dans l'onglet

[From Library]

Dans le champ Manufacturer entrer

Martin

Dans le champ Fixture entrer

Aura

sélectionner Martin Mac Aura Standard - Color Calibration off puis cliquer sur Import Changer le champ Name en Aura Dans le champ Quantity

12

Vider le champ Patch Break 1 Puis cliquer sur le bouton [Apply] Dans la liste Layer : Automatique, dans la colonne Patch sélectionner les 12 projecteurs. Clic-droit sur la sélection. Cliquer sur [Offset]. Dans le champ entrer 20 puis valider avec [Please]. Cliquer sur [Patch to ..], puis entrer 1.1 dans le champ et valider avec [Please]. Dans la liste déplacer vous jusqu'à la colonne Pos X, Sélectionner tous les projecteurs dans la colonne Pos X. Cliquer-droit sur la sélection. Dans le champ entrer

-5.5 Thru 5.5

Valider avec [Please]. Attention si vous utilisez la souris pour cliquer sur les nombres, après le '-' il faut ne pas l'espace insérer. Déplacez-vous sur la colonne Pos Z. Sélectionner tous les projecteurs dans la colonne Pos Z. Puis clic-droit sur la sélection. Entrer 6 dans le champ, puis valider avec [Please]. Recommencer l'insertion de nouveaux projecteurs

[Add Fixture] > [From Library]

Dans le champ Fixture entrer

250+

Choisissez le mode 4 puis

[Import]

Name Mac250 Quantity 12 Fixture Id 101 Vider le champ Patch Break 1 Valider avec [Apply] Dans la colonne Patch sélectionner les 12 nouveaux projecteurs, clic-droit sur la sélection

[Offset]

Entrer 20 dans le champ

[Patch to ...]

Entrer 260 dans le champ Dans la liste déplacer vous jusqu'à la colonne Pos X, Sélectionner tous les projecteurs dans la colonne Pos X. Cliquer-droit sur la sélection. Dans le champ entrer

-5.5 Thru 5.5

Dans la liste déplacer vous jusqu'à la colonne Rot Y, Sélectionner tous les projecteurs dans la colonne Rot Y. Cliquer-droit sur la sélection. Dans le champ entrer

180

Fermer la fenêtre en cliquant sur La Croix. Valider les changements avec [Yes]

[Auto Create] > [Group] 

Sélectionner les MAuraStf puis créer un groupe les contenant tous : [Create All] Valider avec

[OK]

Sélectionner les Mac250+4 puis créer un groupe les contenant tous : [Create All] Valider avec

[OK]

Fermer la fenêtre Auto Create en cliquant sur La Croix.

Fermer la fenêtre Setup/Show/Patch & Fixture Schedule en cliquant sur La Croix.

Sélectionner le [Group 1] puis [Focus] avec la roue codeuse sous Zoom mettre la valeur à zéro. Sélectionner le [Group 2] avec le [Group 1] cliquer sur

[Position] 

Avec le roue codeuse sous Tilt mettre la valeur vers -50

[At] > [Full] > [Please]
[Store] > [115]

Importer une macro [Setup] > [Import Export] > [Import] > [Macros] Dans la liste Choose Macros choisir la macro

Shuffle Selection
[Import]

Fermer la fenêtre Setup/Show/Import Export/Import/Macros

Importer l'effet Circle P/T

[Effects]

Dans la liste Choose Macros choisir l'effet

P/T Circle
[Import]

Fermer la fenêtre Setup/Show/Import Export/Import/Effects

Fermer les fenêtres.

Sélectionner les deux groupes de projecteurs

[Group 1] > [Group 2] > [Shuffle Selection] > [P/T Circle]
[Store] > [Effect 3]

Une belle animation est en route Pour affecter une vitesse avec un potentiomètre:

[Assign] > [Executor 11] > [Special Master]

Cliquer sur le [+] en face de [Master 3 Speed Master] afin de dérouler la liste. Puis cliquer sur :

[SpecialMaster 3.1 Speed 1]

Pour le renommer cliquer sur :

[Label]

Fermer la fenêtre, puis clic-droit sur

[Effect 3]

Sélectionner le contenu de la colonne Speed Group puis clic-droit dans la sélection et choisissez Cercle dans la liste déroulante. Fermer la fenêtre.

Copy Effect 3 at Effect 11
Copy Effect 3 at Effect 12
Copy Effect 3 at Effect 13
Copy Effect 3 at Effect 14

Puis

Edit Effect 11

Cliquer dans la colonne Attrib sur Tilt

[Delete]

Cliquer dans la colonne Attrib sur PAN

[Show Selection] > [-] > [Group 2] > [Take Selection]
[Label]

Taper "PAN Wash" puis valider Fermer la fenêtre

Edit Effect 12

Cliquer dans la colonne Attrib sur Pan

[Delete]

Cliquer dans la colonne Attrib sur TILT

[Show Selection] > [-] > [Group 2] > [Take Selection]
[Label]

Taper "TILT Wash" puis valider Fermer la fenêtre

Faire de même pour les effets 13 et 14 en retirant le groupe 1 et en changeant le Label en Spot au lieu de Wash.

[Assign] >[Executor 10] > [Special Master] > [SpecialMaster 3.1 SpeedMaster 1]
[Label]

Puis entrer Cercle

[Assign] > [Effect 11] > [Executor 12]
[Assign] > [Effect 12] > [Executor 13]
[Assign] > [Effect 13] > [Executor 14]
[Assign] > [Effect 14] > [Executor 15]
[Clear] > [Clear] > [Clear]

Preset

Pour rendre les preset sélectifs par défaut. Appuyer longuement sur

[Store]

Une fenêtre apparait cliquer sur

[Preset Type Default] 

afin de faire apparaître Selective puis

[Save as Default]

Fermer la fenêtre

Preset statiques

Créer une fenêtre basique

[Preset] > [Dynamic]

Cette fenêtre adaptera son contenu en fonction des options sélectionnées. Sélectionner un Group de projecteur ou un projecteur Cliquer deux fois sur

[Position]

Afin de faire apparaître un petit carré rouge sur le bouton, avec les roues codeuses vous pouvez modifier les valeurs de PAN et de TILT Ensuite

[Store] > [Preset1]

Preset dynamiques

Il y a la possibilité de créer des presets dynamiques, c'est-à-dire d'inclure dans le preset des valeurs de fade et de Delay. C'est valeur ne seront pris en compte uniquement une fois une mémoire enregistrée. Le bouton pour indiquer la valeur du fade se situe juste à côté de [Value]

[Fade]

Les contours de [Pan] et [Tilt] sont devenus vert.

[Pan]

Entrer la valeur de fade du preset

[Delay] > [Pan]

Entrer la valeur du Delay. Maintenant dans la ligne centrale du preset, on peut remarquer un tiret jaune qui indique qu'un paramètre en entrer, un tiret vert qui indique qu'un temps de fade est entrer et un tiret marron qui indique qu'un temps de Delay est entrer.

Séquence

Boucle

Déclenchement à l'intérieur d'une boucle

Number CMD Loop Lcount
1 SetUserVar $compteur=0
2
3 Go Executor 108 If $compteur 3
4 AddUserVar $compteur=1 2 4

RDM

Nous pouvons utilisé le protocole RDXM avec la GrandMA 2.

[Setup] > [Patch & Fixture Schedule] > [RDM Devices] > [RDM Disabled]

Une fois le réglage des différents paramètres DMX effectués, n'oubliez pas de désactiver le RDM, sinon des conflits apparaîtront.

[RDM Enabled]

Créer un projecteur

[Setup] > [Patch & Fixture Schedule] > [Fixture Types] > [Add]

Vous pouvez entrer le nom de votre appareil dans le champs proposé.

PAR LED

Une nouvelle ligne d'appareil est créée. Il faut maintenant remplir les différents champs. Les indications ne sont que l'emballage de l'appareil. Elles ne définissent pas les caractéristiques. Pour remplir les champs il faut faire un clic-droit sur la case correspondante.

ShortName : PARLED
Manufacturer : Moi
Mode : Mode 1

Une fois la ligne remplie, nous pouvons éditer l'appareil.

[Edit]

Il faut ensuite ajouter autant de ligne que de paramètres de l'appareil plus un supplémentaire réservé au dimmer. Nous allons donc appuyer 6 fois sur la touche

[Add]

Dans les cases de la colonne Attrib nous allons entrer les différents paramètres. Peu importe l'ordre dans lequel ils sont entrés.

Clic-droit sur la case de la ligne 1 de la colonne Attrib

Nous allons entrer le paramètre de la couleur rouge. Vous pouvez faire défiler la liste vers le bas

[R/C Invert]

Pour le vert

[G/M Invert]

Pour le bleu

[B/Y Invert]

Pour le blanc

[White]

Le cinquième paramètre sera le zoom

[Zoom]

Et le dernier sera un dimmer

[Dim]

Nos informations de couleur sont codées sur 8 bits donc nous n'allons utiliser que la colonne Coarse. Si nous avions un codage sur 16 bits, nous indiquerions un canal DMX pour Fine. Pour simplifier le remplissage de cette colonne, sélectionnez toutes les cases de haut en bas, clic-droit dans la sélection puis taper 1 dans le champ

[Please]

Nous allons ensuite entrer les valeurs par défaut des différents paramètres. Nous allons mettre les valeurs RGB à 100% Sélectionner les trois premières case de la colonne défault puis clic-droit dans la sélection, puis entrer 100 dans le champs

[Please]

Dans la colonne Highlight, Nous allons entrer les valeurs RGB à 100% ainsi que le dimmer. Lors de l'appui sur la touche Highlight en programmation ce sont ces valeurs qui seront utilisées. Clic-droit sur chacune des case et entrer la valeur 100 puis valider avec

[Please]

Fermer la fenêtre. La cases de la colonne DMX Footprint a été modifiée et vous voyez ainsi le nombre de paramètre de l'appareil. Il est nécessaire de l'exporter sur le disque pour que nous puissions l'utiliser. Vous pouvez dès à présent l'utiliser dans le patch.

Utilisation des objets bitmap

Nous allons utiliser 4 Nexus de chez Chauvet pour l'exemple. Nous allons utiliser aussi la fenêtre Layout où sont positionnées les instances des Nexus. Noter le numéro du Layout utilisé, il servira plus tard (par ex 12).

Layout

Dans la fenêtre Layout

[Setup] > [▭]

Créer un rectangle englobant tous les Nexus. Ce rectangle sera la fenêtre dans laquelle sera diffusé le média. Dans la fenêtre qui s'ouvre, indiquer le nom du rectangle. Dans la liste déroulante Visualization, choisir l'option Bitmap.

[Please]

Sélectionner le cadre en cliquant dessus. On peut l'ajuster en utlisant les valeurs Move X et Move Y. Puis

[Position 1 of 3]

Puis modifier les valeurs Size X et Size Y. Sortir du Setup de la fenêtre Layout.

[Setup]

Créer un projecteur virtuel

[Setup] > [Patch & Fixture Schedule]

Vous pouvez créer un nouveau Layer pour co tenir les ressources liées aux médias.

[Layer > [Add Layer]

Entrer le nom du Layer puis rechercher le projecteur

[From Library]

Dans le champ Fixture entrer Bitmap, valider

[Import]

Dans le Fixture Wizard choisissez le Fixture ID ( ainsi que le Patch Break 1, puis

[Apply]

Fermer la fenêtre Edit Setup. Créer un groupe avec le nouveau projecteur et le nommer (Par ex : Grp BMP FX).

Créer une vidéo

On peut utiliser VLC pour encoder des vidéos lisible par la GranMA2.

Fichier > Convertir / Diffuser

Déposer la vidéo que vous souhaitez dans la fenêtre. Choisir le profil Video - VP80 + Vorbis (Webm) puis cliquer sur

[Personnaliser] > [Codecs Video]

Dans la liste déroulante Echelle choisir 0.25

[Codec Audio]

Décocher la case Audio

[Appliquer]
[Enregistrer le fichier] > [Parcourir]

Choisir le nom ainsi que le répertoire de destination. Puis finaliser avec

[Enregistrer]

Dans le bas de la fenêtre principale, on voit la barre de progression pour l'encodage.

Copier ensuite le fichier dans le répertoire

C:\ProgramData\MA Lighting Technologies\grandma\gma2_V_3.2.2\bitmaps

Fichier Image

Ouvrir une fenêtre Images

[Edit] > [case image] > [Import Image]

Vous pouvez choisir soit une image soit un film stocké sur le disque interne ou bien l'importer via une clef USB. Choisir dans la liste déroulante Select Drive le support. Puis parcourir l'arborescence pour trouver le fichier. Puis [Open] Puis fermer la fenêtre.

Affichage

Visualisation sur GrandMA3D de la diffusion d'un film
[Grp BMP FX] > [Dimmer]

Ouvrir le dimmer, puis cliquer sur

[Video]

Ouvrir une fenêtre Smart.

[Output]

Cliquer sur le bouton du Layout utilisé plus haut (ici 12)

[Layout 12]

Ensuite vous pouvez cliquer sur les cases images de la fenêtre Images et les voir s'afficher sur les Nexus.

Trucs bien utiles

  • Dans la fenêtre Stage, si l'onglet Follow est activé tous les projecteurs sélectionnes suivent la souris si le bouton droit est cliqué. Les valeurs sont inscrites dans le programmeur et peuvent être ainsi enregistrés dans des mémoires.
  • Dans MA3D la barre d'espace permet de changer les vues.
  • Pour simuler une gélatine sur des projecteurs traditionnels
 [Setup] > [Patch & Fixture Schedule] 

Clic-droit sur la case de la colonne Colonne correspondant au projecteur. Vous pouvez ainsi choisir la couleur qui vous sied. Si vous souhaitez utiliser une référence du commerce.

[Swatch Book] > [Lee]

Vous pouvez simplifier la recherche en tapant dans le champ Filter la couleur souhaitée. Et validez par

[Please]